FastChar官网
FastChar官网 FastChar
捐助公告
  • 欧克克 863***453@qq.com ¥59.0
  • *💋 180*****471 ¥39.0
  • 懒者 433***782@qq.com ¥39.0
  • 默默猴 874***370@qq.com ¥199.0
  • 认真的猿 116****803@qq.com ¥39.0
  • 爱心 126****357@qq.com ¥39.0
  • 能量 257***146@163.com ¥19.0
  • 水染的天色 113****338@qq.com ¥39.0
  • 微笑的死神 156****158@qq.com ¥39.0
  • 笑话 bai***121@163.com ¥39.0
 无法获取org.apache.velocity.VelocityContext类!请前往 https://mvnrepository.com/artifact/org.apache.velocity/velocity-engine-core 下载并引用必要的Jar包!
  码农我    提问于:2019-08-15 16:02    阅读次数:6352
  

怎么会报这个错误啊,我引用了velocity的jar包啊!


java.lang.UnsupportedClassVersionError: org/apache/velocity/VelocityContext : Unsupported major.minor version 52.0 (unable to load class org.apache.velocity.VelocityContext)

at org.apache.catalina.loader.WebappClassLoaderBase.findClassInternal(WebappClassLoaderBase.java:2254)

at org.apache.catalina.loader.WebappClassLoaderBase.findClass(WebappClassLoaderBase.java:810)

at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1253)

at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1118)

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Class.java:190)

at com.fastchar.utils.FastClassUtils.getClass(FastClassUtils.java:23)

at com.fastchar.core.FastFindClass.find(FastFindClass.java:11)

at com.fastchar.extjs.FastCharExtWeb.onInit(FastCharExtWeb.java:39)

at com.fastchar.core.FastWebs.initWeb(FastWebs.java:60)

at com.fastchar.core.FastEngine.run(FastEngine.java:91)

at com.fastchar.core.FastFilter.init(FastFilter.java:34)

at org.apache.catalina.core.ApplicationFilterConfig.initFilter(ApplicationFilterConfig.java:279)

at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:260)

at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:105)

at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4561)

at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5204)

at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:152)

at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:724)

at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:700)

at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:734)

at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1107)

at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1841)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)

at java.util.concurrent.FutureTask.run(FutureTask.java:262)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

at java.lang.Thread.run(Thread.java:745)

com.fastchar.exception.FastFindException: 无法获取org.apache.velocity.VelocityContext类!请前往 https://mvnrepository.com/artifact/org.apache.velocity/velocity-engine-core 下载并引用必要的Jar包!

at com.fastchar.core.FastFindClass.find(FastFindClass.java:13)

at com.fastchar.extjs.FastCharExtWeb.onInit(FastCharExtWeb.java:39)

at com.fastchar.core.FastWebs.initWeb(FastWebs.java:60)

at com.fastchar.core.FastEngine.run(FastEngine.java:91)

at com.fastchar.core.FastFilter.init(FastFilter.java:34)

at org.apache.catalina.core.ApplicationFilterConfig.initFilter(ApplicationFilterConfig.java:279)

at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:260)

at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:105)

at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:4561)

at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5204)

at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:152)

at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:724)

at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:700)

at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:734)

at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1107)

at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1841)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)

at java.util.concurrent.FutureTask.run(FutureTask.java:262)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

at java.lang.Thread.run(Thread.java:745)

FastChar官网
FastChar 2019-08-15 16:06
   

这个错误是你引用的velocity包要求java必须是1.8以上的sdk,所以FastChar-ExtJs认为没有引用到velocity包!你换成对应支持java 1.7版本的jar就可以了!

https://mvnrepository.com/artifact/org.apache.velocity/velocity/1.7

FastChar官网
码农我  [提问者] 2019-08-15 16:09
   

回复:FastChar

可以了!谢谢!